Skip to content
Permalink
latest
Switch branches/tags
Go to file
 
 
Cannot retrieve contributors at this time
1173 lines (974 sloc) 81.2 KB

Changelog

v8.13.2 (2022-06-29)

Documentation

Dependencies

v8.13.1 (2022-06-23)

Dependencies

v8.13.0 (2022-06-22)

Features

  • 06fd788 #4960 feat: prompt before opening web-login URL when performing login/adduser (@jumoel)

Bug Fixes

Documentation

Dependencies

v8.12.2 (2022-06-15)

Dependencies

v8.12.1 (2022-06-02)

Bug Fixes

v8.12.0 (2022-06-01)

Features

Bug Fixes

Dependencies

v8.11.0 (2022-05-25)

Features

Bug Fixes

Documentation

Dependencies

v8.10.0 (2022-05-11)

Features

Bug Fixes

Dependencies

v8.9.0 (2022-05-04)

Features

Bug Fixes

Documentation

Dependencies

v8.8.0 (2022-04-27)

Features

Bug Fixes

Documentation

Dependencies

v8.7.0 (2022-04-13)

Features

Bug Fixes

Documentation

Dependencies

v8.6.0 (2022-03-31)

Features

Bug Fixes

Documentation

Dependencies

v8.5.5 (2022-03-17)

Bug Fixes

Documentation

Dependencies

v8.5.4 (2022-03-10)

Bug Fixes

Documentation

Dependencies

v8.5.3 (2022-03-03)

Bug Fixes

Dependencies

v8.5.2 (2022-02-24)

Bug Fixes

Documentation

Dependencies

v8.5.1 (2022-02-17)

Dependencies

Documentation

v8.5.0 (2022-02-10)

Features

  • 0cc9d4c51 #4372 feat(deps): @npmcli/config@3.0.0 - introduce automatic workspace roots (@nlf)

Bug Fixes

Documentation

Dependencies

v8.4.1 (2022-02-03)

Bug Fixes

Documentation

Dependencies

v8.4.0 (2022-01-27)

Features

Bug Fixes

Dependencies

v8.3.2 (2022-01-20)

Bug Fixes

Dependencies

v8.3.1 (2022-01-13)

Bug Fixes

  • 2ac540b0c fix(unpublish): Show warning on unpublish command when last version (#4191) (@ebsaral)

Dependencies

Chores

  • d72650457 chore: Bring in all libnpm modules + arborist as workspaces (#4166) (@fritzy)

v8.3.0 (2021-12-09)

Features

Bug Fixes

Documentation

Dependencies

  • e1da1fa4b #4141 deps: @npmcli/arborist@4.1.1: parse-conflict-json@2.0.1
    • Fixes object property assignment bug in resolving package-locks with conflicts
  • 1d8bec566 #4144 #3884 deps: minipass@3.1.6
    • fixes some TAR_ENTRY_INVALID and Z_DATA_ERROR errors

v8.2.0 (2021-12-02)

Features

Bug Fixes

Documentation

Dependencies

v8.1.4 (2021-11-18)

BUG FIXES

DEPENDENCIES

  • 225645420 #3995 update to latest eslint and linting rules (@wraithgar)
  • 203fedf5b #4016 eslint@8.0.0: @npmcli/eslint-config@2.0.0
    • Update to eslint@8 and and @npmcli/eslint-config@2.0.0
    • Remove eslint-plugin-node. Also remove an unused script that was failing linting. We don't use the update-dist-tags script anymore as part of our release process. (@wraithgar)
  • 7b4aa59b6 signal-exit@3.0.6:, tap@15.1.2 (@isaacs)
  • 08015859c #4049 npmlog@6.0.0
  • 088c11694 #4045 node-gyp@8.4.0:
    • feat: support vs2022
    • feat: build with config.gypi from node headers

v8.1.3 (2021-11-04)

BUG FIXES

DEPENDENCIES

  • ac2fabb86 #3990 @npmcli/arborist@4.0.4
    • fix: don't compare spec for local dep vs existing
    • fix: stop pruning peerSets when entryEdge is from a workspace
  • a0d35ff20 #3996 @npmcli/config@2.3.1:
    • fix: dont load project configs in global mode

v8.1.2 (2021-10-28)

BUG FIXES

DEPENDENCIES

v8.1.1 (2021-10-21)

DEPENDENCIES

  • 51fb83ce9 #3921 @npmcli/arborist@4.0.2:
    • fix: skip peer conflict check if there is a current node
  • 1d07f2187 #3913 node-gyp@8.3.0:
    • feat(gyp): update gyp to v0.10.0

v8.1.0 (2021-10-14)

FEATURES

DEPENDENCIES

  • ae4bf013d #3883 pacote@12.0.2:
    • fix: preserve git+ssh url for non-hosted repos
    • deps: update npm-packlist@3.0.0
    • fix: no longer include ignored bundled link deps
  • fbc5a3d08 #3889 @npmcli/ci-detect@1.4.0
  • b6bc279e5 @npmcli/arborist@4.0.1
  • 0f69d295b #3893 @npmcli/map-workspaces@2.0.0

DOCUMENTATION

v8.0.0 (2021-10-07)

The purpose of this release is to drop support for old node versions and to remove support for require('npm'). There are no other breaking changes.

BREAKING CHANGES

  • Drop support for node 10 and 11
  • Raise support ceiling in node 12 and 14 to LTS (^12.13.0/^14.15.0)
  • Drop support to require('npm')
  • Update subdependencies that also dropped node10 support

DEPENDENCIES

  • The following dependencies were updated to drop node10 support and update to the latest node-gyp
    • libnpmversion@2.0.1
    • pacote@12.0.0
    • libnpmpack@3.0.0
    • @npmcli/arborist@3.0.0
    • libnpmfund@2.0.0
    • libnpmexec@3.0.0
    • node-gyp@8.2.0
  • 8bd85cdae #3813 cli-columns@4.0.0